Jump to content


Photo
- - - - -

AVS Script Kepps getting Error


  • Please log in to reply
13 replies to this topic

#1 tw765

tw765

    Junior Member

  • Members
  • Pip
  • 6 posts

Posted 27 May 2010 - 01:08 PM

Hi i installed a AVS script and i keep getting this error.

Not Found

The requested URL /categories was not found on this server.

Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.


when i click a video i get this error:

Not Found

The requested URL /video/2/the-realworkout-banging-hotties-at-the-gym was not found on this server.

Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.



When i go to my website it takes me to the main page which alll works fine.
But when i click on any videos or any other link on the page i get the error. And my admin also works fine.
I also noticed when i put the .PHP at the and its works. example: Normal link

http://xxxxxxxxxxx.co.uk/categories (Not working)
http://xxxxxxxxxxxco.uk/categories.php (works)

Did i do something wrong during installation?

This is how i installed the script

1: created database
2: uploaded the files
3: add my database details
4: Uploaded sql files

Thank you

#2 coscast

coscast

    Banned

  • Banned
  • PipPipPipPip
  • 280 posts

Posted 27 May 2010 - 02:06 PM

Why do you xxx your url?

Its an .xtxcxsx issue :)

Post your Siteurl.

#3 tw765

tw765

    Junior Member

  • Members
  • Pip
  • 6 posts

Posted 27 May 2010 - 03:22 PM

I thought it'll be against the forum rules. Anyway I'm testing it on this domain http//:dboxxonline.co.uk

#4 coscast

coscast

    Banned

  • Banned
  • PipPipPipPip
  • 280 posts

Posted 27 May 2010 - 04:47 PM

Is this a Apache Webserver ? Didn't check the headers.

If yes, you need mod_rewrite for apache and you need to check your htaccess file, also check all your paths in your config.

It's hard to guess from just viewing the site.

#5 jermaine

jermaine

    Banned

  • Banned
  • PipPipPipPip
  • 388 posts

Posted 27 May 2010 - 05:06 PM

This is an .htaccess problem try re uploading your htaccess file to site root. or send me a pm with your FTP let me take a look

Thanks
Jermaine

#6 tw765

tw765

    Junior Member

  • Members
  • Pip
  • 6 posts

Posted 27 May 2010 - 06:18 PM

Hi Jermaine i checked out the .Htaccess file and found the problem and its working now . Thank you so much really appreciate it :)

#7 coscast

coscast

    Banned

  • Banned
  • PipPipPipPip
  • 280 posts

Posted 27 May 2010 - 10:50 PM

HEY! He stole my credits :D:D

I said that first :):)

#8 tw765

tw765

    Junior Member

  • Members
  • Pip
  • 6 posts

Posted 27 May 2010 - 11:01 PM

sorry coscast forgot to thank you to. Thanks for the help :)

#9 coscast

coscast

    Banned

  • Banned
  • PipPipPipPip
  • 280 posts

Posted 27 May 2010 - 11:02 PM

Na, no Problem. Just tried to get a little fun in here :)

#10 jermaine

jermaine

    Banned

  • Banned
  • PipPipPipPip
  • 388 posts

Posted 28 May 2010 - 08:39 AM

Na, no Problem. Just tried to get a little fun in here :)


lol and you welcome again;)


Jermaine

#11 tna

tna

    Member

  • Members
  • PipPip
  • 65 posts

Posted 06 July 2010 - 04:54 AM

Hi Jermaine i checked out the .Htaccess file and found the problem and its working now . Thank you so much really appreciate it :)


Please post what your solution was. I've been searching this forum and I cannot find any posts that are useful in helping me fix my problem. I have the same issue and my .htaccess file is as follows:


# Comment the 2 lines below if the server returns 500 errors!
Options -Indexes
Options +FollowSymLinks

#Uncomment following lines if you want to use image caching!
<IfModule mod_expires.c>
  ExpiresActive On
  ExpiresDefault A1209600
  ExpiresByType text/html A1
</IfModule>

# Uncomment following lines if Apache doesnt support MultiViews!
<IfModule mod_rewrite.c>
    RewriteEngine On
	
	# Uncomment the 2 lines below if you are using www.domain.com
	# as the baseurl for the site and users access your site 
	# via domain.com (THIS IS REQUIRED FOR JQUERY TO WORK)
	
	RewriteCond %{HTTP_HOST} ^mytubesite.com [NC]
	RewriteRule ^(.*)$ http://www.mytubesite.com/$1 [L,R=301] 

    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule .* loader.php [L,QSA]
</IfModule>

# Edit below lines and set to
# ErrorDocument CODE /RELATIVE/error.php
# If the script is installed in the default document
# root then relative is null.
ErrorDocument 401 /error.php
ErrorDocument 403 /error.php
ErrorDocument 404 /error.php

What changes did you make to fix the problem?
I dont want to give access to my server so it would be very helpful to everyone if a solution was posted here.


Thanks.

#12 tna

tna

    Member

  • Members
  • PipPip
  • 65 posts

Posted 06 July 2010 - 01:54 PM

After hours of searching the net on how to fix this I found a solution.
I added
Options -Multiviews
to the top of my .htaccess file and now it works.
  • myavsforums likes this

#13 sexbond

sexbond

    Junior Member

  • Members
  • PipPip
  • 24 posts

Posted 04 February 2011 - 08:47 PM

Hi Jermaine i checked out the .Htaccess file and found the problem and its working now . Thank you so much really appreciate it :)



Hi tw765, i am having the same problem that you had, could you tell me how did you configure your .htaccess or what do i have to do in order to fix the problem? Thanks

#14 myavsforums

myavsforums

    Junior Member

  • Members
  • PipPip
  • 60 posts

Posted 09 May 2017 - 03:07 PM

Folks, I tried this and it also solved my problem

Options Indexes FollowSymLinks MultiViews in apache httpd.conf file

 

 

httpd.conf apache file has #ErrorDocument

remove # and edit the rest as you wish

Alternative way is to create or modify your .htaccess file

 

 

i created /error-documents folder first

I have 5 files

error-401.php

error-402.php

error-403.php

error-404.php

error-500.php

 

so it becomes

ErrorDocument 401 /error-documents/error-401.php

ErrorDocument 402 /error-documents/error-402.php

ErrorDocument 403 /error-documents/error-403.php

ErrorDocument 404 /error-documents/error-404.php

ErrorDocument 500 /error-documents/error-500.php

 

for error404 you can also have /cgi-bin/missing_handler.pl if you want as alternative choice


Edited by myavsforums, 09 May 2017 - 04:01 PM.