Jump to content


Photo
- - - - -

Problem with iphone/mobile plugin

install iphone mobile

  • Please log in to reply
9 replies to this topic

#1 herve51

herve51

    Junior Member

  • Members
  • Pip
  • 4 posts

Posted 21 November 2011 - 09:44 AM

Hello, everything is installed for the plugin iphone/mobile but on the admin page I get this message:
You can convert videos for mobile, but the Mobile Frontend is Disabled.
To enable the Mobile Frontend, you need to purchase and install the "iPhone / Mobile Plugin".
how to fix this ?
thank's

#2 dargre

dargre

    Senior Member

  • Members
  • PipPipPipPipPip
  • 991 posts

Posted 22 November 2011 - 03:19 AM

Probably this is because of not assigned mobile template and a small bug in iphone siteadmin file.

First of all, follow installation tutorial for changes you must set in file "include/config.local.php". One of lines must be:
$config['mobile_template'] = 'mobile_default';
or
$config['mobile_template'] = 'mobile_light';

Then in file "templates/backend/default/index_iphone.tpl" find line:
<option value="mobile_default"{if $mobile_template eq "mobile_default"} selected="selected"{/if}>Mobile Default</option>
and below in new line add:
<option value="mobile_light"{if $mobile_template eq "mobile_light"} selected="selected"{/if}>Mobile Light</option>

This should help.

VIDEO.JS - best HTML5 player in the world for AVS script

NUEVOPLAYER 8 - best flash+html5 player for video scripts
Mods, custom code by NuevoLab (Search Suggest, Multiple image upload, Seo mods,and much more)


#3 herve51

herve51

    Junior Member

  • Members
  • Pip
  • 4 posts

Posted 23 November 2011 - 09:58 AM

Thank you for your answer, I checked everything, I made your changes, but it still does not work. This line of code is good ?

if ($ config ['splash'] == '1 '& &! defined (' _ENTER ') & &! defined (' _admin ') & &! defined (' _MOBILE ') & &! defined (' _CLI '))

#4 herve51

herve51

    Junior Member

  • Members
  • Pip
  • 4 posts

Posted 23 November 2011 - 10:28 AM

Problem solved, thanks for all

#5 zhzubair4

zhzubair4

    Junior Member

  • Members
  • Pip
  • 1 posts

Posted 26 February 2012 - 08:35 AM

spaaming here just delete uper post

Edited by zhzubair4, 04 August 2012 - 12:27 AM.


#6 bigtalk

bigtalk

    Junior Member

  • Members
  • Pip
  • 1 posts

Posted 18 November 2012 - 07:52 AM

herve51, how you solved problem? I have the same troubles :(

#7 faris

faris

    Newbie

  • Members
  • Pip
  • 1 posts

Posted 09 January 2014 - 07:41 AM

Just upgraded to iPhone mod. New uploaded files convert and play. Tested only on iPhone.
How do I convert over 4000 files already uploaded to the site?



#8 myavsforums

myavsforums

    Junior Member

  • Members
  • PipPip
  • 66 posts

Posted 17 October 2015 - 05:05 PM

hello all

i just realized in avs 3.1 i have

defined('_VALID') or die('Restricted Access!');

 

AVS.Mobile.2.0\Mobile.Documentation.html

it says

3. Edit /include/config.php from your server

- Find:
!defined('_ADMIN')
- Replace with:
!defined('_ADMIN') && !defined('_MOBILE')

do i miss something?



#9 myavsforums

myavsforums

    Junior Member

  • Members
  • PipPip
  • 66 posts

Posted 18 October 2015 - 01:55 PM

can somebody please give a similar solution for enabling mobile on version 3.1 please?

this post is from 2011

thank you all



#10 myavsforums

myavsforums

    Junior Member

  • Members
  • PipPip
  • 66 posts

Posted 19 October 2015 - 12:24 PM

when i delete a video from admin panel it deletes from flv hd and all others except iphone

i have to delete manually







Also tagged with one or more of these keywords: install, iphone, mobile