Jump to content


Photo
- - - - -

AVS 4


  • Please log in to reply
8 replies to this topic

#1 fooktube

fooktube

    Member

  • Members
  • PipPip
  • 24 posts

Posted 28 October 2016 - 11:03 PM

Anyone tested AVS 4 is it compatibille with old plugins (storage server etc.)?



#2 apple82

apple82

    Member

  • Members
  • PipPipPipPip
  • 293 posts
  • LocationSpain

Posted 29 October 2016 - 02:34 PM

if, if you look in your account you will see that there plugins for version 4.

graber and embed the graber work wonders.



#3 Damien

Damien

    Junior Member

  • Members
  • PipPipPip
  • 78 posts

Posted 30 October 2016 - 02:18 PM

What's the new features? I see mysql_real_escape_string still! :P



#4 Damien

Damien

    Junior Member

  • Members
  • PipPipPip
  • 78 posts

Posted 30 October 2016 - 02:22 PM

nice move to http://htmlpurifier.org/ with the code. I will add mysqli support and test.

 

lmao wtf

 

/siteadmin/editor_files/INSTALL_HELP.php

 

 

<hr>

<p>Enjoy! That Release From DGT</p>
</body>

 

:rolleyes:


Edited by Damien, 30 October 2016 - 02:30 PM.


#5 theone

theone

    Senior Member

  • Members
  • PipPipPipPip
  • 368 posts

Posted 31 October 2016 - 12:16 AM

They are likely trying to keep 

 

What's the new features? I see mysql_real_escape_string still! :P

 

Looks like it's mainly the admin panel that was updated.

 

http://www.adultvide...oduct/features/

 

Anyway, IMHO any application that is not taking advantage of SPA design concepts is antiquated regardless of the solution stack version.

 

The concept of having the refresh the page every time the user requests new data is an ancient and inefficient concept. I have been developing a pure javascript video sharing app that pushes the templates and most of the logic onto the client. SPA's allow for faster content delivery and a much better user experience. It puts far less responsibility on the server so you can ultimately serve more users.


Edited by theone, 31 October 2016 - 01:14 AM.

  • Damien likes this

#6 desihoes

desihoes

    Senior Member

  • Members
  • PipPipPipPip
  • 380 posts

Posted 31 October 2016 - 03:38 AM

I would have liked to see if we can specify directory for video files in admin instead of using symlinks, if you are hosting data on different drive than the script. It will decrease load on one drive.

I have mysqli enabled on this server but still seeing this in error.log

[30-Oct-2016 03:13:23 UTC] PHP Deprecated:  mysql_connect(): The mysql extension is deprecated and will be removed in the future: use mysqli or PDO instead in /home2/mysite/public_html/test/include/adodb/drivers/adodb-mysql.inc.php on line 364

 

They should fix this forum as well. Every time I login I get the phishing site warning..



#7 Damien

Damien

    Junior Member

  • Members
  • PipPipPip
  • 78 posts

Posted 03 November 2016 - 01:40 PM

I have mysqli enabled on this server but still seeing this in error.log
[30-Oct-2016 03:13:23 UTC] PHP Deprecated:  mysql_connect(): The mysql extension is deprecated and will be removed in the future: use mysqli or PDO instead in /home2/mysite/public_html/test/include/adodb/drivers/adodb-mysql.inc.php on line 364

 
You have to rewrite a ton of functions, I posted a thread here with some examples a while ago. But it's not advisable unless you like grepping a lot of files when each version update arises. All mysql_* functions are going to have to be removed/rewritten at some point or this script will be left in the dust by PHP. Adodb and smarty are also long in the tooth, Adodb's the 2008 '5.08' sourceforge edition, pretty dated these days.


Edited by Damien, 03 November 2016 - 01:50 PM.


#8 desihoes

desihoes

    Senior Member

  • Members
  • PipPipPipPip
  • 380 posts

Posted 06 November 2016 - 04:31 AM

Thanks. Damien

It is too much for me to understand. These guys should move with the times. Best I can do or try is change 'mysql' to 'mysqli' in connect-db-php fiel and that doesn't work :-(

They should fix these little things..



#9 sextube

sextube

    Senior Member

  • Members
  • PipPipPipPip
  • 230 posts

Posted 28 November 2016 - 10:13 PM

they really should think about making it work with PHP7 and Nginx, especially Nginx that is widely used.